Linx Main Linx Help

Error CS0103 when using OR operator with variables


#1

Hi,

We are trying to use the expression editor with a conditional or operator and we get an error when we use a value from previous Linx process.

Our value is “lib_GetFileDetailsByWOID.CFFormatID” and it’s value is an integer outputted from another process called “lib_GetFileDetailsByWOID”.

i.e. In the Expression Editor:
lib_GetFileDetailsByWOID.CFFormatID==9
Returns a True/ False value

lib_GetFileDetailsByWOID.CFFormatID==9||1==1

Returns a True/ False value

When we try to use the lib_GetFileDetailsByWOID.CFFormatID twice
lib_GetFileDetailsByWOID.CFFormatID==9||lib_GetFileDetailsByWOID.CFFormatID==8
An error has occurred:
(241,62): error CS0103: The name ‘lib_GetFileDetailsByWOID_46CFFormatID_17915585’ does not exist in the current context

Are we doing something wrong here, please assist?


#2

Hi Nem,

I’ll try and replicate. Can you please load a Zendesk ticket. Then we can trace the resolution.

Regards,
Dawie


#3

Hi Nem,

I did an example and am not getting the same error. I’ve attached my solution where I tried to get the error, but it worked.

Could you send the solution on Zendesk then I can dig deeper?

Dawie

OrErrorOv.lsoz (5.2 KB)


#4

Hi,
I can reproduce it.
I will send you an LSO. I can’t upload attachments on here because I am a “new user”.


#5

Thank you Nem, I could reproduce the issue. Was a known issue in v5.13. This has now been solved in v5.14.

Regards,
Dawie


#6

Thank you Dawie - we’re upgrading this month!