# Service debugging - Unable to start RESTHost service: Access is denied

**URL:** https://community.linx.software/community/t/service-debugging-unable-to-start-resthost-service-access-is-denied/505
**Category:** Support
**Created:** [January 12, 2021, 6:49am UTC](https://community.linx.software/community/t/service-debugging-unable-to-start-resthost-service-access-is-denied/505 "2021-01-12T06:49:17Z")
**Posts on this page:** 3
**Page:** 1

<div class="post-metadata">

### Author: ![ronan](https://community.linx.software/community/user_avatar/community.linx.software/ronan/32/433_2.png) [@ronan](https://community.linx.software/community/u/ronan)
#### Post date: [January 12, 2021, 6:49am UTC](https://community.linx.software/community/t/service-debugging-unable-to-start-resthost-service-access-is-denied/505/1 "2021-01-12T06:49:17Z")

</div>

When service debugging a [RESTHostSVC](https://linx.software/docs/reference/plugins/rest/content/resthost) or [SimpleRESTHostSVC](https://linx.software/docs/reference/plugins/rest/content/simpleresthost) locally with a **Base URI** similar to `http://localhost:8080/path` and you receive the below error:

```http
Unable to start RESTHost service: 
Access is denied

```

Re-open in the Linx Designer with administrator rights (“ **Run as administrator** ”) and then open your Solution.

---

<div class="post-metadata">

### Author: ![ronan](https://community.linx.software/community/user_avatar/community.linx.software/ronan/32/433_2.png) [@ronan](https://community.linx.software/community/u/ronan)
#### Post date: [April 13, 2021, 11:30am UTC](https://community.linx.software/community/t/service-debugging-unable-to-start-resthost-service-access-is-denied/505/2 "2021-04-13T11:30:40Z")

</div>

Some users may experience the below error when service debugging a REST service locally.

```http
Unable to start SimpleRESTHost service
The process cannot access the file because it is being used by another process

```

To address the problem, follow the steps listed in [this article](https://docs.microsoft.com/en-us/previous-versions/windows/it-pro/windows-server-2008-R2-and-2008/cc727839(v=ws.10)?redirectedfrom=MSDN).

---

<div class="post-metadata">

### Author: ![ronan](https://community.linx.software/community/user_avatar/community.linx.software/ronan/32/433_2.png) [@ronan](https://community.linx.software/community/u/ronan)
#### Post date: [June 8, 2021, 1:02pm UTC](https://community.linx.software/community/t/service-debugging-unable-to-start-resthost-service-access-is-denied/505/3 "2021-06-08T13:02:10Z")

</div>

Just a note that some users may experience issues going from debugging locally to deploying on their Linx Cloud Server instance.

When you are debugging the service locally, the RESTHost/SimpleRESTHost service runs locally on your PC within the Linx Designer instance itself, that why it has no problem accessing localhost resources such as your database if you’ve setup the correct pwd and username in the connection string (For example if you have integrated security set to “true” on a database connection string).

When you deploy to a Linx application cloud server, your solution is hosted on the Linx application server which runs on an azure instance in the “cloud”. If you want to connect to a database or other data sources you will need to configure your target data source to accept connections and you will also have to setup access rights etc as well as update your connection details on the Linx side so that it can connect.

Also take note about changing the Base URL when deploying to the Linx application cloud server, more details can be found [here](https://community.linx.software/community/t/cloud-server-api-deployment/535).
