Linx Main Linx Help

Email Read Error

Hi darkonesic82,

Welcome to the Linx Community.

I’ll test a couple of things using similar settings to yours, but having a look at your properties, all seems fine. Unfortunately I’ve got no access to your server, so won’t be able to see what happens on your email server. I’ll use one of my own to test.

Best regards,

Thanks for the support. I am awaiting for your feedback.

Hi darkonesic82,

I had a look at your server and it seems to be a normal CPanel email server. I’ve tried connecting to it but kept getting the same errors as you.

To test if it’s an issue with Linx, I’ve used a different CPanel domain that I’ve got and set up the email using the same configuration you are using. On my server it works perfectly, but on yours I get the socket error. The issue here seems to be on the routing / DNS settings of your domain. Can you confirm if your Outlook connects to your server on that same port number?


As a test, you can use my server and password above to see if you can connect to my server, but I’m going to disable this email address after today.

Also these are main settings with pass two so please try it in real.


Will test, but we’ll have to delete all these screenshots afterwards.

No problem Dawie.
We will change pass two.

Same error. I’ve asked our Dev team to have a look. It’s something to do with the email server’s settings, not the account itself.

Thanks a lot. Please if I can do something on our email server settings tell me.

Hi Dawie,

I found out right now that our mail server support TLS1.2 protocol.
Is it possible that this can be a problem?


Thank you for this, yes, our development team have found the issue. It is related to the server, which is valid, but the underlying tech on the email plugin was still on the previous release. So they are busy updating the email plugin and releasing it today. They’ve tested it with your email and it works. I’ll let you know as soon as it is available for you to use.

Best regards,


The new Email plugin has been released. Just quit your Linx, open it again, and click “Check for updates” on the Plugins. The new plugin version is 1.7.3. To view which plugin is on your solution, just hover over the (i) icon next to the plugin name:

Screenshot 2020-01-30 at 14.23.22

Hello Dawie,

I am using on premise version old one, not cloud.
I don’t have update for email after checking the list of plugins. My version is


Just close Linx and reopen, then create a new Solution? If you’ve selected “Check for updates” it should have downloaded the plugin. is really old.


Which version of Linx are you using?

If you’re using 5.13 or less, then unfortunately the new plugins will not be working. The current version is 5.17.

I am using 5.13.9671.0

I don’t have suggestion for a new releases everything is up to date.

Unfortunately Linx 5.13 was the end of the BETA version. 5.14 was launched as 'n licensed version. In order to keep users on 5.13 free, we did not push their version to 5.14. You can download the latest 5.17 from our site, the Designer is still free, however, the Server part is now licensed.


After I upgrade the designer to a new version I got the following error:

StartSolution failed LoadSolution failed Error resolving type specified in JSON ‘Twenty57.Linx.Plugin.Common.Types.CompiledTypeReference, Twenty57.Linx.Plugin.Common, Version=, Culture=neutral, PublicKeyToken=d7f03d358506bc3d’. Path ‘$type’, line 1, position 173. Could not load assembly ‘Twenty57.Linx.Plugin.Common, Version=, Culture=neutral, PublicKeyToken=d7f03d358506bc3d’.


Thank you for the message. Can you provide me with the scenario for when you get this error?

The “StartSolution” error normally occurs on Linx Server, and if you try to run a 5.17 Solution on a 5.13 server this error could occur.


Yes this is the situation. This error occurs on server.
So this upgrade of Read Email we can not use with free version?
We are in the phase of testing the solution for our future customers and we are acctually the integrator of different IT solutions.
Is it possible to get from you dealer demo like we have lets say with Nicelabel and Mecalux EasyWMS solutions, where we create some standard app with lets say your background processes automation and like whole solution sell to end user?