Linx Main Linx Help

Quick MySQL Setup and test on Linx

MySQL is a great database tool if you need a powerful database, but free to use. However, it does take a couple more steps to set it up and get it working on Linx. I have followed these steps to connect to MySQL with Linx.

  1. First, I’ve installed MySQL, by installing WAMP on a new Windows server, from . This is a quick way to get a working MySQL server up and running with the required admin tools like phpMyAdmin. Remember the default username and password for MySQL on WAMP is root with a blank password. The default MySQL port is 3306

  2. Then I created a small database called LinxTest with a table with the following structure, and added a couple of rows of data to test on:


  3. To connect to this database, you’ll have to install the ODBC drivers for MySQL.

  4. Run the ODBC Data Sources utility to add a new Data source:


**Please note from comments below, select the “System DSN” tab if you want to run your solution in Linx Server.

  1. Create a new data source and give it a DSN (Data source name):

  2. Use the new DSN and set up a connection on your Linx Database function, using ODBC as the connection type (i.e. ExecuteSQL):

Done, now you can perform data queries, stored procedures etc on a MySQL Database.

Example solution (Linx 5.14):
MySQLTest (1).lsoz (4.5 KB)

1 Like


When I start the solution in Designer, it works perfect, but when started from Server. it returns an error.

EventException, 64e423a6b8d04c179265a12b44173bb6, Twenty57.Linx.Runtime.SDK.LinxException: TimerEvent.Process: Process.ExecuteSQL: ERROR [IM002] [Microsoft][ODBC Driver Manager] Data source name not found and no default driver specified —>

What could be the problem?

note: I use ODBC driver for MySQL, and works fine starting from Linx Designer.

Hi Mojito,

Thank you for highlighting this. I missed a step after (4). Please add the new Data Source Name under the “System DSN” tab (and not the default User tab). This will allow your System processes (like Linx Server) to find your database.



Thanks a lot guys. It works fine for me now.

Thanks once again.

Quick note to add, if you do not want to do the DSN step in setting up a MySQL connection, you can simply expand the Connection string with the details:

Uid=root;Pwd=******;Driver={MySQL ODBC 8.0 ANSI Driver};Server=;Database=LinxHosting;

image001 (1)

1 Like